Globe DSL Compatibility Question

Discussion in 'DSL & Info Tech News' started by J.Fernandez, Aug 31, 2012.

  1. I was looking on to buying this:


    and was wondering if it will work with globe?

    And for those know it all folks who said any modem router would work....
    well the answer is NO this will be my 3rd modem attempt if ever I already bought a CDRKING & an ENCORE modem and non of them worked, so experienced people please give me hope!

  2. josekym

    josekym Member

    Can you be more specific as to how you configured the modems you've tried in the past? Especially the WAN or DSL side of the modems.

    Seen these?:


  3. Yup, I configured it that way previously.
    Status would show it was connected but still won't show activity all it would do is go to the tattoo page telling yo to call globe.

    Now back to my orig question, has anyone tried this particular modem?

    Since the threads date back quite a bit and I don't think I could find those particular models.
  4. josekym

    josekym Member

    In the modem status, do you get a public IP address (i.e. 180.191.x.x, 120.28.x.x, etc.), or is it a private one (i.e. 192.168.x.x, 10.x.x.x, 172.16.x.x, etc.)

    Are you presented with the Globe "portal" upon opening your web browser? You usually the Globe "portal" if:

    1) Your PPPoE account was changed or is different
    2) You changed your modem

    I think that the Globe DSL system "knows" the MAC address of the issued modem and ties that to the PPPoE account (or phone number, not sure)... The best approach so far, has been to turn the Globe issued modem-router into a modem only device (i.e. bridge mode) and then run your own router behind it to host the Internet connection.

    Haven't actually tried the modem you mentioned, but looking at the manual and specs should make it compatible. There is nothing much you can configure on the WAN/DSL side of it, except the usual Connection Type, VPI/VCI, LLC, et al.

  5. Exactly according to one of the Globe techs there are a series of addresses allocated for modems, he just can't tell which brands would or would not work. I know for a fact an old TP Link worked but unfortunately if overheated and eventually was unusable.

    Can anyone at least tell me which AVAILABLE brands were tried and tested on Globe.

  6. This is perhaps a bit late (over a year later!) but I figured that my information could be useful to someone on here.

    You can use a TP-Link W8951ND 150M with Globe DSL, but it's a bit annoying to make it work. Unfortunately, Globe filter PPPoE requests (PADI frames) by MAC address - this is how they stop you using gear other than their own. In order to use any DSL equipment other than what Globe provide, you'll either need to ask Globe to allow your device's MAC address, or spoof the MAC address on your new equipment to be the same as the Globe modem's Ethernet interface.

    I have reached this conclusion by setting up the TP-Link as a "1483 Bridge" device with the correct VPI/VCI, so it's establishing the DSL connection/virtual circuit but not establishing the PPPoE tunnel. Then I've used a Mikrotik RB1200 (you could use any PPPoE client really, including the one built into Windows) to establish a PPPoE tunnel. With the standard MAC address on the Mikrotik's Ethernet interface, PADI frames sent to the ISP do not receive any response (and so you can't reach the Internet!). As soon as I changed the Mikrotik's Ethernet interface MAC address to that of the Globe DSL modem (note that I was using the TP-Link at this stage in order to avoid MAC address conflicts), the PPPoE tunnel came up as it should and I had Internet access.

    I'm not sure if you can change the MAC address of the TP-Link in order to allow it to establish the PPPoE tunnel. If you try to use the TP-Link, or any device other than the one given to you by Globe, you will be unable to establish a PPPoE tunnel (and therefore you'll have no Internet). You'll most likely need to call Globe and ask them to allow the MAC address of the TP-Link. This explains why you've tried 3 different modems and none have worked.

Share This Page