CDRKING CW-G1 3G Router Firmware Upgrade Hack

Discussion in 'CDR King products' started by bridge, Jan 10, 2013.


  1. bridge

    bridge Member




    CDRKING CW-G1 3G Router Firmware Upgrade Hack


    Hi guys

    after owning this cdrking 3g USB router (CW-G1), I decided to open this and see
    if i can find a better firmware than the original cdrking firmware.

    cdrking-cwg1.jpg



    Gladly after opening it up, I found that this CW-G1 3G usb router firmware is using
    RALINK RT3050F chipset

    cd-r-king-cw-g1-usb-3g-router.jpg


    also it has a board code BP ML E186014
    cdrking-usb3g-router.jpg

    After some searching, I decide to "suicidely" try the Edimax 6200N firmware which has the same chipset from RAlink, after careful check with the 6200N hardware it has bigger board, several LAN ports and but still has 3G usb port... so i guess its time to try and if it bricks, then bye bye cdrking 3g router :D

    So i downloaded the latest Edimax 6200n 3g router firmware from their website.
    http://www.edimax.com/en/support_detail.php?pd_id=312&pl1_id=3#02

    the latest version as of this upgrade is 3G-6200n_v2.26
    I login to the cdrking usb 3g cw-g1 routers ip address 192.168.20.1
    then tools-->firmware upgrade


    upload the edimax firmware and seems good news, its uploading...
    cdr-king-cw-g1-3g-usb-router.jpg


    After few minutes, its done.
    I reset the router by holding the reset button beside the antenna for 30 seconds.
    then i removed the power supply, after 1 minute plug it back.

    voila! its powering up!!! :D
    the default ip of the edimax firmware is 192.168.2.1
    cdrking-cw-g1-edimax-6200n.jpg


    After some testing, yes its working!
    Firmware upgrade of cdr king Cw-g1 3G usb router to Edimax 6200 firmware is SUCCESSFUL.

    For owners of the same cdrking 3g router, I HIGHLY RECOMMEND to upgrade your firmware to edimax as its better firmware, additional features and more stable.

    Hope that helps guys....
     
  2. bridge

    bridge Member




    Theres also a hidden command page
    http://192.168.2.1/syscmd.asp

     
    josekym likes this.
  3. josekym

    josekym Member




    Nice find, and congrats on your discovery! :)
     



  4. my CW-G1 experiencing instability like, constantly request timeouts and dns errors... after searching for some firmware upgrade, google brought me here.... i tried it and it worked! thanks man!
     



  5. Ayus to ha. :D
    Thanks
     
                                 

Share This Page